Kommentarer: Bröööööl (Eller, vad som verkligen gör världen korkad)

För att fixa din RSS/RDF-fil, läs längst ner på http://hotwired.lycos.com/webmonkey/03/17/index3a_page4.html?tw=authoring

Du måste kapsla in ö-kodningen i titeln på ditt flöde mha CDATA-taggen, då borde det fungera...

Kommentar från johan, januari 7, 2004 09:46 FM

Jag har provat det - men det hjälper inte. Det fixar bara det första ö-et, i titelns "Blind Höna". XML-filen blir ogiltig så fort den når nästa svenska tecken - i beskrivningen, "upphittat på nätet..."

Fixar jag det, blir filen i alla fall ogiltig så fort första svenska tecken i en POST dyker upp:

Problemet är att ALLA svenska tecken i min XML-fil - i alla inlägg - visas med ampersand-koder. Och det kan jag inte ändra.

Inkapslingen av åäö i title och description med CDATA leder också till konstiga effekter för utskickningen av notification-mejl med mera.

Min enda gissning är denna: i MTs template för XML-filen genereras allting - title, description, entries - med taggar med denna kodning

MTBlogName encode_html="1"

MTEntryTitle encode_html="1"
MTEntryExcerpt encode_html="1"

Jag kommer nu att ändra
encode_html="1"
i mallarnas taggar till
remove_html="1" encode_xml="1"
istället och se om det hjälper...

(Varför just mina mallar har fått denna kodning vet jag inte. Min MT-installation är version 2.64. Version 2.65 har den där alternativa kodningen. och i en sådan installation, på samma webbhotell, fungerar XML-flödet trots svenska tecken...)

Kommentar från Jonas, januari 7, 2004 11:05 FM

Skriv en egen kommentar:
Namn:


Mejladress:


URL (webblog, hemsida etc):




Webadresser i ditt inlägg blir automatiskt länkar om du skriver dem som http://www.url.com


Kommentar:


Kom ihåg personuppgifter